hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haohui Mai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6328) Simplify code in FSDirectory
Date Mon, 05 May 2014 22:58:17 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6328?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13990066#comment-13990066

Haohui Mai commented on HDFS-6328:

The main motivation of this jira is to perform identical code clean up to make the reviews
of HDFS-6330 and HDFS-6315 easier.

The original motivation is to make sure there is no OutOfBoundException in the loop locally
without going through all the traces, but it looks the order of the clauses is wrong. I'll
fix it in another patch.

> Simplify code in FSDirectory
> ----------------------------
>                 Key: HDFS-6328
>                 URL: https://issues.apache.org/jira/browse/HDFS-6328
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>         Attachments: HDFS-6328.000.patch, HDFS-6328.001.patch
> This jira proposes:
> # Cleaning up dead code in FSDirectory.
> # Simplify the control flows that IntelliJ flags as warnings.
> # Move functions related to resolving paths into one place.

This message was sent by Atlassian JIRA

View raw message