hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6267) Upgrade Jetty6 to Jetty9
Date Tue, 22 Apr 2014 02:56:17 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13976331#comment-13976331
] 

Andrew Wang commented on HDFS-6267:
-----------------------------------

Hey [~azuryy]! Thanks for putting in the work here, but unfortunately you've stepped into
a very touchy subject :)

If you look on common-dev, there was a big thread about updating for JDK7, and Jetty is related
to that. The consensus was that we can't do this in branch-2 at least because of compatibility
concerns unless we shade our internal dependencies. It'd be technically fine to do this in
trunk for 3.0 (like this JIRA's affects version indicates), but I personally am against divergence
between trunk and branch-2 until there's a clear plan for releasing a Hadoop 3.0. Other developers
also feel this way.

This is also a change that would need a lot of testing, since Jetty is used in a lot of places
in Hadoop.

> Upgrade Jetty6 to Jetty9
> ------------------------
>
>                 Key: HDFS-6267
>                 URL: https://issues.apache.org/jira/browse/HDFS-6267
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Fengdong Yu
>            Assignee: Fengdong Yu
>            Priority: Minor
>         Attachments: HDFS-6267.patch
>
>
> Jetty stable version is 9.x, but it requires Java7, so I want to target 3.0 for this
upgrade.
> Jetty9 is incompatible with Jetty6, so the patch will be big.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message