hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-6006) Remove duplicate code in FSNameSystem#getFileInfo
Date Wed, 26 Feb 2014 14:01:30 GMT

    [ https://issues.apache.org/jira/browse/HDFS-6006?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13912926#comment-13912926
] 

Hudson commented on HDFS-6006:
------------------------------

SUCCESS: Integrated in Hadoop-Hdfs-trunk #1685 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1685/])
HDFS-6006. Remove duplicate code in FSNameSystem#getFileInfo. Contributed by Akira Ajisaka.
(cnauroth: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1571813)
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java


> Remove duplicate code in FSNameSystem#getFileInfo
> -------------------------------------------------
>
>                 Key: HDFS-6006
>                 URL: https://issues.apache.org/jira/browse/HDFS-6006
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: 2.3.0
>            Reporter: Akira AJISAKA
>            Assignee: Akira AJISAKA
>            Priority: Trivial
>              Labels: newbie
>             Fix For: 3.0.0, 2.4.0
>
>         Attachments: HDFS-6006.patch
>
>
> In FSNameSystem#getFileInfo, it checks src file name two times.
> {code}
>     if (!DFSUtil.isValidName(src)) {
>       throw new InvalidPathException("Invalid file name: " + src);
>     }
>     HdfsFileStatus stat = null;
>     FSPermissionChecker pc = getPermissionChecker();
>     checkOperation(OperationCategory.READ);
>     if (!DFSUtil.isValidName(src)) {
>       throw new InvalidPathException("Invalid file name: " + src);
>     }
> {code}
> The latter should be removed.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message