hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5948) TestBackupNode flakes with port in use error
Date Thu, 13 Feb 2014 21:54:19 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5948?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13900777#comment-13900777
] 

Hadoop QA commented on HDFS-5948:
---------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12628815/HDFS-5948.000.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6142//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6142//console

This message is automatically generated.

> TestBackupNode flakes with port in use error
> --------------------------------------------
>
>                 Key: HDFS-5948
>                 URL: https://issues.apache.org/jira/browse/HDFS-5948
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.2.0
>            Reporter: Andrew Wang
>            Assignee: Haohui Mai
>         Attachments: HDFS-5948.000.patch
>
>
> TestBackupNode has flaked on our internal Jenkins and I found it in a few test-patch
runs upstream too. Error like this:
> {noformat}
> Error Message:
> Port in use: 0.0.0.0:50105
> Stack Trace:
> java.lang.AssertionError: Port in use: 0.0.0.0:50105
>         at org.junit.Assert.fail(Assert.java:91)
>         at org.junit.Assert.assertTrue(Assert.java:43)
>         at org.apache.hadoop.hdfs.server.namenode.TestBackupNode.testCheckpoint(TestBackupNode.java:295)
>         at org.apache.hadoop.hdfs.server.namenode.TestBackupNode.testCheckpointNode(TestBackupNode.java:124)
> ...
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message