hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HDFS-5860) Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature helper method.
Date Sat, 01 Feb 2014 05:56:09 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5860?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth resolved HDFS-5860.
---------------------------------

       Resolution: Fixed
    Fix Version/s: HDFS ACLs (HDFS-4685)
     Hadoop Flags: Reviewed

+1 for the patch.  I committed it to the HDFS-4685 feature branch.  Thanks for taking care
of this so quickly, Jing.

> Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature helper
method.
> --------------------------------------------------------------------------------------------
>
>                 Key: HDFS-5860
>                 URL: https://issues.apache.org/jira/browse/HDFS-5860
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>    Affects Versions: HDFS ACLs (HDFS-4685)
>            Reporter: Chris Nauroth
>            Assignee: Jing Zhao
>            Priority: Minor
>             Fix For: HDFS ACLs (HDFS-4685)
>
>         Attachments: HDFS-5860.000.patch
>
>
> The HDFS-4685 feature branch has introduced a helper method for getting an inode feature
of a particular class: {{INodeWithAdditionalFields#getFeature}}.  Currently, this is only
called by code related to ACLs, but we can also use the same method to reduce code duplication
in the various {{INodeDirectory}} methods that get different kinds of features.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message