hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5551) Rename "path.based" caching configuration options
Date Mon, 25 Nov 2013 18:30:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5551?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13831708#comment-13831708
] 

Colin Patrick McCabe commented on HDFS-5551:
--------------------------------------------

I'm not sure if we want to rename these.  For example, if we rename {{dfs.namenode.path.based.cache.refresh.interval.ms}}
to {{dfs.namenode.cache.refresh.interval.ms}}, it starts to sound awfully generic.

The rename that removed "PathBased" from a bunch of class names was just a matter of necessity--
the names were getting too cumbersome, and we didn't think there would be conflicts.  With
the config keys, a long name is not such a big problem since we only use them once or twice
throughout the code.  And it does help to disambiguate them from all the other cache configurations
we have (and there are many)

> Rename "path.based" caching configuration options
> -------------------------------------------------
>
>                 Key: HDFS-5551
>                 URL: https://issues.apache.org/jira/browse/HDFS-5551
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
>            Priority: Minor
>
> Some configuration options still have the "path.based" moniker, missed during the big
rename removing this naming convention.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message