hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5473) Consistent naming of user-visible caching classes and methods
Date Thu, 21 Nov 2013 06:57:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13828555#comment-13828555
] 

Hadoop QA commented on HDFS-5473:
---------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12615049/HDFS-5473.003.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 4 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/5518//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/5518//console

This message is automatically generated.

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-5473.002.patch, HDFS-5473.003.patch
>
>
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}}
methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}.
We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message