hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5473) Consistent naming of user-visible caching classes and methods
Date Tue, 12 Nov 2013 03:20:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13819779#comment-13819779

Andrew Wang commented on HDFS-5473:

It was also brought to my attention that CachePoolInfo is marked Private right now, while
it should be Public Evolving like PBCD.

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Andrew Wang
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}}
methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}.
We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.

This message was sent by Atlassian JIRA

View raw message