hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5473) Consistent naming of user-visible caching classes and methods
Date Thu, 21 Nov 2013 00:03:35 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13828319#comment-13828319
] 

Andrew Wang commented on HDFS-5473:
-----------------------------------

This looks great. I ran an `ack-grep PathBased` though and found some references to PathBasedCache*
still though, want to sed those out too? Looks like a few log messages, method names, javadoc.

+1 pending `ack-grep -l PathBased | wc -l` printing 0 and Jenkins, thanks Colin.

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-5473.002.patch
>
>
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}}
methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}.
We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message