hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-5473) Consistent naming of user-visible caching classes and methods
Date Wed, 20 Nov 2013 23:39:37 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Colin Patrick McCabe updated HDFS-5473:
---------------------------------------

    Status: Patch Available  (was: Open)

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-5473.002.patch
>
>
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}}
methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}.
We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message