hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5473) Consistent naming of user-visible caching classes and methods
Date Wed, 20 Nov 2013 23:39:36 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5473?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13828305#comment-13828305

Colin Patrick McCabe commented on HDFS-5473:

I did the renaming we discussed.  I also added the caching commands to {{HdfsAdmin}}.  Finally,
{{listDirectives}} now returns an entry containing info and stats.  This avoids the problems
we talked about earlier where the info structure has fields that aren't usually applicable
to add, modify, etc operations.

> Consistent naming of user-visible caching classes and methods
> -------------------------------------------------------------
>                 Key: HDFS-5473
>                 URL: https://issues.apache.org/jira/browse/HDFS-5473
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: 3.0.0
>            Reporter: Andrew Wang
>            Assignee: Colin Patrick McCabe
>         Attachments: HDFS-5473.002.patch
> It's kind of warty that (after HDFS-5326 goes in) DistributedFileSystem has {{*CachePool}}
methods take a {{CachePoolInfo}} and {{*PathBasedCacheDirective}} methods that thake a {{PathBasedCacheDirective}}.
We should consider renaming {{CachePoolInfo}} to {{CachePool}} for consistency.

This message was sent by Atlassian JIRA

View raw message