hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5360) Improvement of usage message of renameSnapshot and deleteSnapshot
Date Thu, 17 Oct 2013 13:20:47 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13797880#comment-13797880
] 

Hudson commented on HDFS-5360:
------------------------------

FAILURE: Integrated in Hadoop-Hdfs-trunk #1555 (See [https://builds.apache.org/job/Hadoop-Hdfs-trunk/1555/])
Move HDFS-5360 to 2.2.1 in CHANGES.txt (wang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1532935)
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
HDFS-5360. Improvement of usage message of renameSnapshot and deleteSnapshot. Contributed
by Shinichi Yamashita. (wang: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1532930)
* /hadoop/common/trunk/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/SnapshotCommands.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/snapshot/TestSnapshotDeletion.java
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/snapshot/TestSnapshotRename.java


> Improvement of usage message of renameSnapshot and deleteSnapshot
> -----------------------------------------------------------------
>
>                 Key: HDFS-5360
>                 URL: https://issues.apache.org/jira/browse/HDFS-5360
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: snapshots
>    Affects Versions: 3.0.0
>            Reporter: Shinichi Yamashita
>            Assignee: Shinichi Yamashita
>            Priority: Minor
>             Fix For: 2.2.1
>
>         Attachments: HDFS-5360.patch, HDFS-5360.patch
>
>
> When the argument of "hdfs dfs -createSnapshot" comamnd is inappropriate, it is displayed
as follows.
> {code}
> [hadoop@trunk ~]$ hdfs dfs -createSnapshot
> -createSnapshot: <snapshotDir> is missing.
> Usage: hadoop fs [generic options] -createSnapshot <snapshotDir> [<snapshotName>]
> {code}
> On the other hands, the commands of "-renameSnapshot" and "-deleteSnapshot" is displayed
as follows. And there are not kind for the user.
> {code}
> [hadoop@trunk ~]$ hdfs dfs -renameSnapshot
> renameSnapshot: args number not 3: 0
> [hadoop@trunk ~]$ hdfs dfs -deleteSnapshot
> deleteSnapshot: args number not 2: 0
> {code}
> It changes "-renameSnapshot" and "-deleteSnapshot" to output the message which is similar
to "-createSnapshot".



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message