hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5360) Improvement of usage message of renameSnapshot and deleteSnapshot
Date Wed, 16 Oct 2013 22:08:51 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13797339#comment-13797339

Hadoop QA commented on HDFS-5360:

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 2 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:red}-1 eclipse:eclipse{color}.  The patch failed to build with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-common-project/hadoop-common

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/5214//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/5214//console

This message is automatically generated.

> Improvement of usage message of renameSnapshot and deleteSnapshot
> -----------------------------------------------------------------
>                 Key: HDFS-5360
>                 URL: https://issues.apache.org/jira/browse/HDFS-5360
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: snapshots
>    Affects Versions: 3.0.0
>            Reporter: Shinichi Yamashita
>            Assignee: Shinichi Yamashita
>            Priority: Minor
>         Attachments: HDFS-5360.patch, HDFS-5360.patch
> When the argument of "hdfs dfs -createSnapshot" comamnd is inappropriate, it is displayed
as follows.
> {code}
> [hadoop@trunk ~]$ hdfs dfs -createSnapshot
> -createSnapshot: <snapshotDir> is missing.
> Usage: hadoop fs [generic options] -createSnapshot <snapshotDir> [<snapshotName>]
> {code}
> On the other hands, the commands of "-renameSnapshot" and "-deleteSnapshot" is displayed
as follows. And there are not kind for the user.
> {code}
> [hadoop@trunk ~]$ hdfs dfs -renameSnapshot
> renameSnapshot: args number not 3: 0
> [hadoop@trunk ~]$ hdfs dfs -deleteSnapshot
> deleteSnapshot: args number not 2: 0
> {code}
> It changes "-renameSnapshot" and "-deleteSnapshot" to output the message which is similar
to "-createSnapshot".

This message was sent by Atlassian JIRA

View raw message