hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uma Maheswara Rao G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5331) make SnapshotDiff.java to a o.a.h.util.Tool interface implementation
Date Thu, 10 Oct 2013 19:33:43 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5331?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13791902#comment-13791902
] 

Uma Maheswara Rao G commented on HDFS-5331:
-------------------------------------------

Have verified with this change?
1) SnapshotDiff class should have set conf otherwise conf will be null right?
 2) While you are setting conf please use HdfsConfiguration.
3) will this be good of considering generic opts for this command?

Please comment on additional test failures reported. Should not be related.

> make SnapshotDiff.java to a o.a.h.util.Tool interface implementation
> --------------------------------------------------------------------
>
>                 Key: HDFS-5331
>                 URL: https://issues.apache.org/jira/browse/HDFS-5331
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: snapshots
>    Affects Versions: 3.0.0, 2.1.1-beta
>            Reporter: Vinay
>            Assignee: Vinay
>         Attachments: HDFS-5331.patch
>
>
> SnapshotDiff.java is a plain class with main() method now. 
> Convert it to o.a.h.util.Tool interface implementation for better look and usage  in
tests in future,



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message