hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HDFS-5224) Refactor PathBasedCache* methods to use a Path rather than a String
Date Fri, 11 Oct 2013 19:45:42 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5224?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Nauroth resolved HDFS-5224.
---------------------------------

       Resolution: Fixed
    Fix Version/s: HDFS-4949
     Hadoop Flags: Reviewed

I've committed this to the HDFS-4949 branch.  Thanks for the reviews!

> Refactor PathBasedCache* methods to use a Path rather than a String
> -------------------------------------------------------------------
>
>                 Key: HDFS-5224
>                 URL: https://issues.apache.org/jira/browse/HDFS-5224
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: HDFS-4949
>            Reporter: Andrew Wang
>            Assignee: Chris Nauroth
>             Fix For: HDFS-4949
>
>         Attachments: HDFS-5224.1.patch, HDFS-5224.2.patch, HDFS-5224.3.patch
>
>
> As discussed in HDFS-5213, we should refactor PathBasedCacheDirective and related methods
in DistributedFileSystem to use a Path to represent paths to cache, rather than a String.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message