hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-5224) Refactor PathBasedCache* methods to use a Path rather than a String
Date Fri, 11 Oct 2013 18:52:45 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5224?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Chris Nauroth updated HDFS-5224:

    Attachment: HDFS-5224.3.patch

I'm attaching patch version 3.  The differences since last time are:

# {{CacheAdmin}}: Removed redundant null check.
# {{EmptyPathError}}: This is back in a slightly different form.  Since it's now impossible
to instantiate a {{PathBasedCacheDirective}} with an empty path, the check is enforced at
the protocol in the translator.  I've added a new unit test at this layer too.

I decided to leave {{validate}} alone.  Andrew, I hit a snag when I tried calling it from
{{build}}.  The validation logic includes a call to {{DFSUtil#isValidName}}.  That method
checks that it's an absolute path.  We want to enable callers to instantiate with a relative
path and have it resolved by the DFS, so doing this validation at build time conflicts with
that.  The check for an absolute path is still helpful at the time that {{CacheManager}} is
working on it, so I just left the whole thing alone.

> Refactor PathBasedCache* methods to use a Path rather than a String
> -------------------------------------------------------------------
>                 Key: HDFS-5224
>                 URL: https://issues.apache.org/jira/browse/HDFS-5224
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: HDFS-4949
>            Reporter: Andrew Wang
>            Assignee: Chris Nauroth
>         Attachments: HDFS-5224.1.patch, HDFS-5224.2.patch, HDFS-5224.3.patch
> As discussed in HDFS-5213, we should refactor PathBasedCacheDirective and related methods
in DistributedFileSystem to use a Path to represent paths to cache, rather than a String.

This message was sent by Atlassian JIRA

View raw message