hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5224) Refactor PathBasedCache* methods to use a Path rather than a String
Date Mon, 07 Oct 2013 20:50:42 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13788552#comment-13788552
] 

Colin Patrick McCabe commented on HDFS-5224:
--------------------------------------------

er, wait, I think I misunderstood Chris's proposal. 

No, I am *not* saying we add {{Path}} to {{PathBasedCacheEntry}}.  I'm saying we add a method
in {{DistributedFileSystem}} that takes a {{Path}} and returns a {{PathBasedCacheEntry}} initialized
with the correct {{String}} (or a builder initialized with the correct string)


> Refactor PathBasedCache* methods to use a Path rather than a String
> -------------------------------------------------------------------
>
>                 Key: HDFS-5224
>                 URL: https://issues.apache.org/jira/browse/HDFS-5224
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: HDFS-4949
>            Reporter: Andrew Wang
>            Assignee: Chris Nauroth
>         Attachments: HDFS-5224.1.patch
>
>
> As discussed in HDFS-5213, we should refactor PathBasedCacheDirective and related methods
in DistributedFileSystem to use a Path to represent paths to cache, rather than a String.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message