hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arpit Agarwal (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-5264) Consider renaming StorageID
Date Wed, 25 Sep 2013 23:58:02 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5264?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arpit Agarwal updated HDFS-5264:
--------------------------------

    Description: 
We should consider renaming StorageID to something else since we have changed the meaning
of the field. Previously it was used to identify the single logical storage attached to a
datanode and hence it was a de-facto identifier for a Datanode. Now the StorageID identifies
a single storage. To avoid confusion of meaning especially when merging with other feature
branches it may be best to rename it to something else.

We can do so when merging phase 1 of the Heterogeneous Storage work into trunk.

A partial list of places to update:
# FsVolumeSpi#storageID
# DatanodeStorageInfo#storageID
# DatanodeStorage#storageID
# StorageReceivedDeletedBlocks#storageID
# StorageReport#storageID
# LocatedBlock#storageIDs
# processFirstBlockReport
# DatanodeStorage#getStorageInfo
# TestDatanodeDescriptor#testBlocksCounter
# TestBlockManager.java
# FsDatasetSpi#getBlockReports

  was:
We should consider renaming StorageID to something else since we have changed the meaning
of the field. Previously it was used to identify the single logical storage attached to a
datanode and hence it was a de-facto identifier for a Datanode. Now the StorageID identifies
a single storage. To avoid confusion of meaning especially when merging with other feature
branches it may be best to rename it to something else.

We can do so when merging back phase 1 of the Heterogeneous Storage work into trunk.

A partial list of places to update:
# FsVolumeSpi#storageID
# DatanodeStorageInfo#storageID
# DatanodeStorage#storageID
# StorageReceivedDeletedBlocks#storageID
# StorageReport#storageID
# LocatedBlock#storageIDs
# processFirstBlockReport
# DatanodeStorage#getStorageInfo
# TestDatanodeDescriptor#testBlocksCounter
# TestBlockManager.java
# FsDatasetSpi#getBlockReports

    
> Consider renaming StorageID
> ---------------------------
>
>                 Key: HDFS-5264
>                 URL: https://issues.apache.org/jira/browse/HDFS-5264
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>            Reporter: Arpit Agarwal
>
> We should consider renaming StorageID to something else since we have changed the meaning
of the field. Previously it was used to identify the single logical storage attached to a
datanode and hence it was a de-facto identifier for a Datanode. Now the StorageID identifies
a single storage. To avoid confusion of meaning especially when merging with other feature
branches it may be best to rename it to something else.
> We can do so when merging phase 1 of the Heterogeneous Storage work into trunk.
> A partial list of places to update:
> # FsVolumeSpi#storageID
> # DatanodeStorageInfo#storageID
> # DatanodeStorage#storageID
> # StorageReceivedDeletedBlocks#storageID
> # StorageReport#storageID
> # LocatedBlock#storageIDs
> # processFirstBlockReport
> # DatanodeStorage#getStorageInfo
> # TestDatanodeDescriptor#testBlocksCounter
> # TestBlockManager.java
> # FsDatasetSpi#getBlockReports

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message