hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Li (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5212) Refactor RpcMessage and NFS3Response to support different types of authentication information
Date Tue, 17 Sep 2013 22:03:53 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5212?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13770051#comment-13770051
] 

Brandon Li commented on HDFS-5212:
----------------------------------

Patch looks good!
Some comments:
1. writeHeaderAndResponse could be a better name than sendHeaderAndResponse, since the method
doesn't really "send" anything.
2. please move RpcCall.read method back to it original location in RpcCall
3. Since RpcCall.write seralizes verifier and credential, these tests need to be fixed:  
      
TestOutOfOrderWrite, TestPortmapRegister
                
> Refactor RpcMessage and NFS3Response to support different types of authentication information
> ---------------------------------------------------------------------------------------------
>
>                 Key: HDFS-5212
>                 URL: https://issues.apache.org/jira/browse/HDFS-5212
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: nfs
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>         Attachments: HDFS-5212.001.patch
>
>
> Currently the authentication information is hard coded in RpcMessage (and its subclasses)
and NFS3Response (and its subclasses) as AuthFlavor value and empty byte array. We need to
refactor this part of code to support different types of authentication information.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message