hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Junping Du (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5188) Clean up BlockPlacementPolicy and its implementations
Date Sun, 15 Sep 2013 01:48:51 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13767647#comment-13767647

Junping Du commented on HDFS-5188:

Thanks for nice work, Nicholas! The patch looks good to me. Only a minor comment here: I see
EMPTY_ARRAY defined twice here, once in DatanodeDescriptor and the other in DatanodeInfo,
can we leave DatanodeDescriptor.EMPTY_ARRAY only? 
I have no further comments any more. Given this is a patch for trunk, may be you need a committer's
> Clean up BlockPlacementPolicy and its implementations
> -----------------------------------------------------
>                 Key: HDFS-5188
>                 URL: https://issues.apache.org/jira/browse/HDFS-5188
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h5188_20130912b.patch, h5188_20130912.patch, h5188_20130914.patch
> Below is a list of code cleanup tasks for BlockPlacementPolicy and its implementations:
> - Define constants for dfs.block.replicator.classname.
> - Combine adjustExcludedNodes and addToExcludedNodes: subclasses should always add all
the related nodes in addToExcludedNodes(..).
> - Remove duplicated code.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message