hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Junping Du (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5188) Clean up BlockPlacementPolicy and its implementations
Date Sat, 14 Sep 2013 03:15:53 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13767341#comment-13767341

Junping Du commented on HDFS-5188:

Thanks for quickly response, Nicholas!
3. Agree. It may be helpful for RAID cases. Just curious on where the code of BlockPlaceementPolicyRaid
going? I remember we used to have that. Am I missing anything here?
4. Sure. Just filed HDFS-5207 to address this.
I will review your new patch soon. Thx!
> Clean up BlockPlacementPolicy and its implementations
> -----------------------------------------------------
>                 Key: HDFS-5188
>                 URL: https://issues.apache.org/jira/browse/HDFS-5188
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h5188_20130912b.patch, h5188_20130912.patch, h5188_20130914.patch
> Below is a list of code cleanup tasks for BlockPlacementPolicy and its implementations:
> - Define constants for dfs.block.replicator.classname.
> - Combine adjustExcludedNodes and addToExcludedNodes: subclasses should always add all
the related nodes in addToExcludedNodes(..).
> - Remove duplicated code.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message