hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-5188) Clean up BlockPlacementPolicy and its implementations
Date Thu, 12 Sep 2013 18:08:52 GMT

    [ https://issues.apache.org/jira/browse/HDFS-5188?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13765712#comment-13765712
] 

Hadoop QA commented on HDFS-5188:
---------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12602818/h5188_20130912b.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 5 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/4960//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/4960//console

This message is automatically generated.
                
> Clean up BlockPlacementPolicy and its implementations
> -----------------------------------------------------
>
>                 Key: HDFS-5188
>                 URL: https://issues.apache.org/jira/browse/HDFS-5188
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h5188_20130912b.patch, h5188_20130912.patch
>
>
> Below is a list of code cleanup tasks for BlockPlacementPolicy and its implementations:
> - Define constants for dfs.block.replicator.classname.
> - Combine adjustExcludedNodes and addToExcludedNodes: subclasses should always add all
the related nodes in addToExcludedNodes(..).
> - Remove duplicated code.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message