hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kihwal Lee (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HDFS-5083) Update the HDFS compatibility version range
Date Fri, 09 Aug 2013 18:56:49 GMT

     [ https://issues.apache.org/jira/browse/HDFS-5083?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kihwal Lee resolved HDFS-5083.
------------------------------

       Resolution: Fixed
    Fix Version/s: 2.1.0-beta
     Hadoop Flags: Incompatible change,Reviewed

Thanks for the review, Suresh. I've committed this to branch-2, branch-2.1-beta and branch-2.1.0-beta.

                
> Update the HDFS compatibility version range
> -------------------------------------------
>
>                 Key: HDFS-5083
>                 URL: https://issues.apache.org/jira/browse/HDFS-5083
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 2.1.0-beta, 2.3.0
>            Reporter: Kihwal Lee
>            Priority: Blocker
>             Fix For: 2.1.0-beta
>
>         Attachments: HDFS-5083.branch-2.x.patch
>
>
> Since we have made incompatible changes including RPCv9, the following needs to be updated.
For branch-2 and branch-2.*,  I think it needs to be set to 2.1.0.
> DFS_NAMENODE_MIN_SUPPORTED_DATANODE_VERSION_DEFAULT
> DFS_DATANODE_MIN_SUPPORTED_NAMENODE_VERSION_DEFAULT
> The rpc change will make dn registration fail, so it won't get to the actual version
check, but this still needs to be set correctly, since we are aiming 2.1.0 to be api/protocol
stable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message