hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Junping Du (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4987) Namenode changes to track multiple storages
Date Tue, 27 Aug 2013 01:19:52 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13750845#comment-13750845

Junping Du commented on HDFS-4987:

Nicholas, nice code refactoring work on reportDiff(...). Previous delimiter seems to be non-necessary.
My only question is if we remove TestBlockInfo.java which is only unit test and consumer of
moveBlockToHead() in DataNodeDescriptor/BlockInfo, shall we consider to remove this method
rather than leaving there without using and testing?
> Namenode changes to track multiple storages
> -------------------------------------------
>                 Key: HDFS-4987
>                 URL: https://issues.apache.org/jira/browse/HDFS-4987
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Suresh Srinivas
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h4987_20130822.patch, h4987_20130827.patch
> Currently namenode track in BlockInfo, the corresponding DataNodeDescriptor. I propose
changing this with new abstraction StorageDescriptor. This change will also make DatanodeDescriptor
a collection of StroageDescriptors. This will allow given a block, identify its storage and
also Datanode.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message