hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cristina L. Abad (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4869) FsShell get command does not support writing to stdout
Date Mon, 10 Jun 2013 15:47:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4869?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13679585#comment-13679585
] 

Cristina L. Abad commented on HDFS-4869:
----------------------------------------

I tried these things and they all worked with the current patch:

hdfs dfs -get /path/to/aFile -
Result: file is printed to stdout

hdfs dfs -get /path/to/aDirWithTwoFiles/* -
Result: content of both files is printed to stdout

hdfs dfs -get /path/to/aFileThatDoesNotExist -
Result: error message "No such file or directory"

hdfs dfs -get /path/to/aFile* -
Result: prints the two files that match "aFile*" to stdout

hdfs dfs -get /path/to/aDirWithTwoFiles -
Result: error message: "Is a directory"

I guess you were referring to the last case in your comment. I thought this was the same behavior
of the prior "-get aDir -" implementation, but I could be wrong about this.

In any case, I am OK with leaving it as won't fix; at least this jira now documents the fact
that "-get aDir -" does not work in the current versions of Hadoop.


                
> FsShell get command does not support writing to stdout
> ------------------------------------------------------
>
>                 Key: HDFS-4869
>                 URL: https://issues.apache.org/jira/browse/HDFS-4869
>             Project: Hadoop HDFS
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.1.0-beta, 0.23.8
>            Reporter: Cristina L. Abad
>            Assignee: Cristina L. Abad
>            Priority: Minor
>         Attachments: 4869.branch-0.23.patch
>
>
> In FsShell the put command supports using "\-" in place of stdin, but this functionality
("\-" in place of stdout) is broken in the get command.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message