hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4848) copyFromLocal and renaming a file to ".snapshot" should output that ".snapshot" is a reserved name
Date Wed, 29 May 2013 08:49:20 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13669099#comment-13669099
] 

Hadoop QA commented on HDFS-4848:
---------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12585163/HDFS-4848.001.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 core tests{color}.  The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

                  org.apache.hadoop.hdfs.server.namenode.snapshot.TestRenameWithSnapshots

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/4447//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/4447//console

This message is automatically generated.
                
> copyFromLocal and renaming a file to ".snapshot" should output that ".snapshot" is a
reserved name
> --------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-4848
>                 URL: https://issues.apache.org/jira/browse/HDFS-4848
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: snapshots
>    Affects Versions: 3.0.0
>            Reporter: Stephen Chu
>            Assignee: Jing Zhao
>            Priority: Trivial
>              Labels: snapshot, snapshots
>         Attachments: HDFS-4848.000.patch, HDFS-4848.001.patch
>
>
> Might be an unlikely scenario, but if users copyFromLocal a file/dir from local to HDFS
and want the file/dir to be renamed to _.snapshot_, then they'll see an Input/output error
 like the following:
> {code}
> schu-mbp:~ schu$ hdfs dfs -copyFromLocal testFile1 /tmp/.snapshot
> copyFromLocal: rename `/tmp/.snapshot._COPYING_' to `/tmp/.snapshot': Input/output error
> {code}
> It'd be more clear if the error output was the usual _".snapshot" is a reserved name_
(this does show in the NN logs, though).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message