hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Chu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-4848) copyFromLocal and renaming a file to ".snapshot" should output that ".snapshot" is a reserved name
Date Fri, 24 May 2013 18:42:22 GMT

     [ https://issues.apache.org/jira/browse/HDFS-4848?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stephen Chu updated HDFS-4848:
------------------------------

    Labels: snapshot snapshots  (was: )
    
> copyFromLocal and renaming a file to ".snapshot" should output that ".snapshot" is a
reserved name
> --------------------------------------------------------------------------------------------------
>
>                 Key: HDFS-4848
>                 URL: https://issues.apache.org/jira/browse/HDFS-4848
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 3.0.0
>            Reporter: Stephen Chu
>            Priority: Trivial
>              Labels: snapshot, snapshots
>
> Might be an unlikely scenario, but if users copyFromLocal a file/dir from local to HDFS
and want the file/dir to be renamed to _.snapshot_, then they'll see an Input/output error
 like the following:
> {code}
> schu-mbp:~ schu$ hdfs dfs -copyFromLocal testFile1 /tmp/.snapshot
> copyFromLocal: rename `/tmp/.snapshot._COPYING_' to `/tmp/.snapshot': Input/output error
> {code}
> It'd be more clear if the error output was the usual _".snapshot" is a reserved name_
(this does show in the NN logs, though).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message