hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4719) Minor simplifications to snapshot code
Date Sun, 21 Apr 2013 07:11:16 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4719?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13637494#comment-13637494
] 

Tsz Wo (Nicholas), SZE commented on HDFS-4719:
----------------------------------------------

Patch looks good.  I think there is bug in the code below.
{code}
+      if (snapshotCopy == null && diff.snapshotINode == null) {
+        diff.saveSnapshotCopy(createSnapshotCopy(currentINode), currentINode);
+      }
{code}
It should be:
{code}
      if (diff.snapshotINode == null) {
        if (snapshotCopy == null) {
          snapshotCopy = createSnapshotCopy(currentINode);
        }
        diff.saveSnapshotCopy(snapshotCopy, currentINode);
      }
{code}

                
> Minor simplifications to snapshot code
> --------------------------------------
>
>                 Key: HDFS-4719
>                 URL: https://issues.apache.org/jira/browse/HDFS-4719
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: Snapshot (HDFS-2802)
>            Reporter: Arpit Agarwal
>            Assignee: Arpit Agarwal
>             Fix For: Snapshot (HDFS-2802)
>
>         Attachments: HDFS-4719.002.patch
>
>
> Remove couple of unused snapshot functions and factor away the factory classes.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message