hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-4464) Combine collectSubtreeBlocksAndClear with deleteDiffsForSnapshot
Date Sat, 02 Feb 2013 01:21:11 GMT

     [ https://issues.apache.org/jira/browse/HDFS-4464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Tsz Wo (Nicholas), SZE updated HDFS-4464:

    Attachment: h4464_20120201b.patch

Sure, destroySubtreeAndCollectBlocks sounds like a better name.

h4464_20120201b.patch: renames the method and also revises the javadoc.
> Combine collectSubtreeBlocksAndClear with deleteDiffsForSnapshot
> ----------------------------------------------------------------
>                 Key: HDFS-4464
>                 URL: https://issues.apache.org/jira/browse/HDFS-4464
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h4464_20120201b.patch, h4464_20120201.patch
> Both collectSubtreeBlocksAndClear and deleteDiffsForSnapshot are recursive methods for
deleting inodes and collecting blocks for further block deletion/update.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message