hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4189) rename getter method getMutableX and getXMutable to getXAndEnsureMutable
Date Fri, 01 Feb 2013 13:28:18 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4189?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13568734#comment-13568734
] 

Hudson commented on HDFS-4189:
------------------------------

Integrated in Hadoop-Hdfs-Snapshots-Branch-build #88 (See [https://builds.apache.org/job/Hadoop-Hdfs-Snapshots-Branch-build/88/])
    HDFS-4189. Renames the getMutableXxx methods to getXxx4Write and fix a bug that some getExistingPathINodes
calls should be getINodesInPath4Write. (Revision 1441193)

     Result = FAILURE
szetszwo : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1441193
Files : 
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/CHANGES.HDFS-2802.txt
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSDirectory.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSEditLogLoader.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSImageFormat.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSNamesystem.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/FSPermissionChecker.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeDirectory.java
* /hadoop/common/branches/HDFS-2802/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/snapshot/SnapshotManager.java

                
> rename getter method getMutableX and getXMutable to getXAndEnsureMutable
> ------------------------------------------------------------------------
>
>                 Key: HDFS-4189
>                 URL: https://issues.apache.org/jira/browse/HDFS-4189
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>    Affects Versions: Snapshot (HDFS-2802)
>            Reporter: Brandon Li
>            Assignee: Tsz Wo (Nicholas), SZE
>            Priority: Minor
>             Fix For: Snapshot (HDFS-2802)
>
>         Attachments: h4189_20130130.patch, h4189_20130131.patch
>
>
> The method names with the form "getMutableXxx" may be misleading.  Let's rename them.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message