hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4441) Refactor INodeDirectoryWithSnapshot.Diff as a top level generic class
Date Fri, 25 Jan 2013 19:27:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4441?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13562932#comment-13562932
] 

Jing Zhao commented on HDFS-4441:
---------------------------------

The patch looks good to me. Only some minor issues:
1. Maybe Triple, Pair, and Single can be renamed as DiffUndoInfo/DiffModLineage, SnapshotCopyPair,
and PreviousINodeState, respectively? And maybe Triple and Single can be moved into the Diff
class?
2. GetKey seems more like a method name?
3. It would be better to have javadoc in Diff to explain the selection of the value of DEFAULT_ARRAY_INITIAL_CAPACITY.

                
> Refactor INodeDirectoryWithSnapshot.Diff as a top level generic class
> ---------------------------------------------------------------------
>
>                 Key: HDFS-4441
>                 URL: https://issues.apache.org/jira/browse/HDFS-4441
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: h4441_20130124.patch
>
>
> INodeDirectoryWithSnapshot.Diff is for recording the difference between the current state
and a previous state of the children list of an INodeDirectory.  It is easy to refactor the
code to support generic lists.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message