hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4422) Upgrade servlet-api dependency from version 2.5 to 3.0.
Date Wed, 23 Jan 2013 18:11:14 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13560886#comment-13560886
] 

Steve Loughran commented on HDFS-4422:
--------------------------------------

Before we move, I've just been looking at jetty + servlet API 3 details on the web

2008 ref to jetty 7: http://docs.codehaus.org/display/JETTY/Continuations

jetty 7 + 8 details: http://wiki.eclipse.org/Jetty/Feature/Continuations

the implication here is that continuations (which allow you to release/resume a request, have
the servlet engine push the request to some stack and pop it later) in the jetty6 API will
work on jetty 7+ 8, but there's an implict hint here that the servlet 3.0 equivalent only
work on jetty7+. 

That is: not everything in the 3.0 servlet API is in Jetty6. 

If there are things in the 3.0 API that people need to use, they should have explicit unit
tests to verify they work, and everyone should know which features of the API are missing
-& where you should fallback to jetty-specific details
                
> Upgrade servlet-api dependency from version 2.5 to 3.0.
> -------------------------------------------------------
>
>                 Key: HDFS-4422
>                 URL: https://issues.apache.org/jira/browse/HDFS-4422
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.0.3-alpha
>            Reporter: Plamen Jeliazkov
>            Assignee: Plamen Jeliazkov
>            Priority: Minor
>             Fix For: 3.0.0, 2.0.3-alpha
>
>         Attachments: HDFS-4422.patch
>
>
> Please update the servlet-api jar from 2.5 to javax.servlet 3.0 via Maven:
> <dependency>
>         <groupId>javax.servlet</groupId>
>         <artifactId>javax.servlet-api</artifactId>
>         <version>3.0.1</version>
>         <scope>provided</scope>
> </dependency>
> I am running a 2.0.3 dev-cluster and can confirm compatibility. I have removed the servlet-api-2.5.jar
file and replaced it with javax.servlet-3.0.jar file. I am using javax.servlet-3.0 because
it implements methods that I use for a filter, namely the HttpServletResponse.getStatus()
method.
> I believe it is a gain to have this dependency as it allows more functionality and has
so far proven to be backwards compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message