hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4422) Upgrade servlet-api dependency from version 2.5 to 3.0.
Date Sat, 19 Jan 2013 02:36:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13557893#comment-13557893
] 

Hadoop QA commented on HDFS-4422:
---------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12565588/HDFS-4422.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

      {color:red}-1 javac{color}.  The applied patch generated 2023 javac compiler warnings
(more than the trunk's current 2021 warnings).

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in hadoop-client hadoop-common-project/hadoop-auth
hadoop-common-project/hadoop-auth-examples hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs
hadoop-hdfs-project/hadoop-hdfs-httpfs hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy.

    {color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/3860//testReport/
Javac warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/3860//artifact/trunk/patchprocess/diffJavacWarnings.txt
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/3860//console

This message is automatically generated.
                
> Upgrade servlet-api dependency from version 2.5 to 3.0.
> -------------------------------------------------------
>
>                 Key: HDFS-4422
>                 URL: https://issues.apache.org/jira/browse/HDFS-4422
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 2.0.3-alpha
>            Reporter: Plamen Jeliazkov
>            Assignee: Plamen Jeliazkov
>            Priority: Minor
>             Fix For: 3.0.0, 2.0.3-alpha
>
>         Attachments: HDFS-4422.patch
>
>
> Please update the servlet-api jar from 2.5 to javax.servlet 3.0 via Maven:
> <dependency>
>         <groupId>javax.servlet</groupId>
>         <artifactId>javax.servlet-api</artifactId>
>         <version>3.0.1</version>
>         <scope>provided</scope>
> </dependency>
> I am running a 2.0.3 dev-cluster and can confirm compatibility. I have removed the servlet-api-2.5.jar
file and replaced it with javax.servlet-3.0.jar file. I am using javax.servlet-3.0 because
it implements methods that I use for a filter, namely the HttpServletResponse.getStatus()
method.
> I believe it is a gain to have this dependency as it allows more functionality and has
so far proven to be backwards compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message