hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4352) Encapsulate arguments to BlockReaderFactory in a class
Date Wed, 09 Jan 2013 03:30:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4352?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13547594#comment-13547594

Colin Patrick McCabe commented on HDFS-4352:

Although I don't feel strongly about it, I agree with Todd-- using a builder here would be
better than having 8 to 12 argument methods.  We use the builder pattern in many other places,
such as {{MiniDFSCluster#Builder}}, {{DFSTestUtil#Builder}}, and so forth.  There are even
builders in the standard library like {{StringBuilder}}.  That pattern should be familiar
to everyone.  It would have been nice if the discussion had moved in that direction, and hopefully
there is still a chance to consider that.

Nicholas, when I said we could revert this, I was referring to this JIRA-- not to HDFS-4353.
 It seems very irregular to revert HDFS-4353 with no community discussion.
> Encapsulate arguments to BlockReaderFactory in a class
> ------------------------------------------------------
>                 Key: HDFS-4352
>                 URL: https://issues.apache.org/jira/browse/HDFS-4352
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs-client
>    Affects Versions: 2.0.3-alpha
>            Reporter: Colin Patrick McCabe
>         Attachments: 01b.patch, 01.patch
> Encapsulate the arguments to BlockReaderFactory in a class to avoid having to pass around
10+ arguments to a few different functions.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message