hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4317) Change INode to support HDFS-4103
Date Mon, 17 Dec 2012 03:18:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13533612#comment-13533612

Tsz Wo (Nicholas), SZE commented on HDFS-4317:

> INode#createSnapshotCopy - "The original inode usually is this inode." What is "this"
inode? I am also not clear why "original inode is the new inode" relevant to the javadoc?

"this" inode is the calling object, i.e. the this object reference in Java.  I replaced "original
inode" with "current inode".  

> INodeDirectory#replaceINodeFile4Snapshot - javadoc talks about replacing child, but does
not mention snapshot. However method name mentions snapshot. Btw why cannot we just call it

Renamed it to replaceINodeFile.

> INodesInPath#path is not currently not used. I assume it will be used in later patches?

Yes, it is for printing debug message.

h4317_20121216b.patch: makes the changes above.  Also adds some toString methods and new tests
for the undo methods.
> Change INode to support HDFS-4103
> ---------------------------------
>                 Key: HDFS-4317
>                 URL: https://issues.apache.org/jira/browse/HDFS-4317
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Tsz Wo (Nicholas), SZE
>         Attachments: 4317.INodeDirectoryWithSnapshot.patch, h4317_20121216b.patch, h4317_20121216.patch
> This is a subtask separated from HDFS-4103:
> - Change Diff to support undo.
> - Add createSnapshotCopy() for inode
> - Reorganize the INode and its subclasses constructors and some other methods.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message