hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4152) Add a new class for the parameter in INode.collectSubtreeBlocksAndClear(..)
Date Tue, 06 Nov 2012 18:32:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4152?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13491683#comment-13491683

Aaron T. Myers commented on HDFS-4152:

The change looks fine to me, but why make this change on trunk instead of the HDFS-2802 branch?
There doesn't seem to be any motivation to make this change except to support snapshots.
> Add a new class for the parameter in INode.collectSubtreeBlocksAndClear(..)
> ---------------------------------------------------------------------------
>                 Key: HDFS-4152
>                 URL: https://issues.apache.org/jira/browse/HDFS-4152
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>    Affects Versions: 3.0.0
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Jing Zhao
>            Priority: Minor
>         Attachments: HDFS-4152.001.patch
> INode.collectSubtreeBlocksAndClear(..) currently uses a list to collect blocks for deletion.
 It cannot be extended to support other operation like updating the block-map.  We propose
to add a new class to encapsulate the abstraction. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message