hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-4095) Add snapshot related metrics
Date Fri, 02 Nov 2012 03:02:12 GMT

    [ https://issues.apache.org/jira/browse/HDFS-4095?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489220#comment-13489220

Suresh Srinivas commented on HDFS-4095:

# numSnapshotDirs should be named numSnapshots. Similarly getNumSnapshotDirs() should be getNumSnapshots()
# increment and decremente SnapshottableDirNum should be called with in SnapshotManager. Move
it to appropriate method in SnapshotManager.
# Please create a jira to write tests for all the metrics, including the ones you have added
in this jira.

BTW this patch also needs to be rebased.
> Add snapshot related metrics
> ----------------------------
>                 Key: HDFS-4095
>                 URL: https://issues.apache.org/jira/browse/HDFS-4095
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Jing Zhao
>            Assignee: Jing Zhao
>         Attachments: HDFS-4095.001.patch, HDFS-4095.002.patch
> Add metrics for number of snapshots in the system, including 1) number of snapshot files,
and 2) number of snapshot only files (snapshot file that are not deleted but the original
file is already deleted).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message