hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3537) Move libhdfs and fuse-dfs source to native subdirectories
Date Mon, 16 Jul 2012 04:26:34 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3537?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13414842#comment-13414842

Eli Collins commented on HDFS-3537:

Hey Colin,

Script looks good, I had to update it slightly to reflect the latest libhdfs changes.

Looks like fuse-dfs now compiles by default whereas it previously only built when -Pfuse was
passed, we need to preserve that behavior since we support the native build on non-linux systems.

> Move libhdfs and fuse-dfs source to native subdirectories
> ---------------------------------------------------------
>                 Key: HDFS-3537
>                 URL: https://issues.apache.org/jira/browse/HDFS-3537
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: contrib/fuse-dfs, libhdfs
>    Affects Versions: 2.0.0-alpha
>            Reporter: Colin Patrick McCabe
>            Assignee: Colin Patrick McCabe
>            Priority: Minor
>             Fix For: 2.1.0-alpha
>         Attachments: HDFS-3537.001.patch, do.sh
> Move libhdfs source files from main/native to main/native/libhdfs.  Rename hdfs_read
to libhdfs_test_read; rename hdfs_write to libhdfs_test_write.
> The rationale is that we'd like to add some other stuff under main/native (like fuse_dfs)
and it's nice to have separate things in separate directories.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message