hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3388) GetJournalEditServlet should catch more exceptions, not just IOException
Date Tue, 08 May 2012 21:09:49 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13270832#comment-13270832

Todd Lipcon commented on HDFS-3388:

Good idea. Maybe we should also rename CheckpointFaultInjector to FileTransferFaultInjector
or something? Or split it in two, since if I recall correctly some of the fault points are
checkpoint-specific whereas others are just for the GetImageServlet.
> GetJournalEditServlet should catch more exceptions, not just IOException
> ------------------------------------------------------------------------
>                 Key: HDFS-3388
>                 URL: https://issues.apache.org/jira/browse/HDFS-3388
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ha, name-node
>            Reporter: Brandon Li
>            Assignee: Brandon Li
>         Attachments: HDFS-3388.HDFS-3092.patch
> GetJournalEditServlet has the same problem as that of GetImageServlet (HDFS-3330). It
should be fixed in the same way. Also need to make CheckpointFaultInjector visible for journal
service tests.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message