hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HDFS-3417) Rename BalancerDatanode#getName to getDisplayName to be consistent with Datanode
Date Wed, 16 May 2012 05:54:25 GMT

     [ https://issues.apache.org/jira/browse/HDFS-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Todd Lipcon updated HDFS-3417:
------------------------------

    Fix Version/s:     (was: 2.0.0)
                   2.0.1
    
> Rename BalancerDatanode#getName to getDisplayName to be consistent with Datanode
> --------------------------------------------------------------------------------
>
>                 Key: HDFS-3417
>                 URL: https://issues.apache.org/jira/browse/HDFS-3417
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 2.0.0
>            Reporter: Eli Collins
>            Assignee: Eli Collins
>            Priority: Minor
>             Fix For: 2.0.1
>
>         Attachments: hdfs-3417.txt
>
>
> Let's rename BalancerDatanode#getName to getDisplayName to be consistent with Datanode,
since it's used for logging. Also makes the code less confusing as "getName" in the context
of DataNode/Node usually refers to a network location, not a display name.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message