hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3375) Put client name in DataXceiver thread name for readBlock and keepalive
Date Sat, 05 May 2012 01:27:50 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13268848#comment-13268848
] 

Hadoop QA commented on HDFS-3375:
---------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12525704/hdfs-3375.txt
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    -1 javadoc.  The javadoc tool appears to have generated 2 warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    +1 core tests.  The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/2381//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/2381//console

This message is automatically generated.
                
> Put client name in DataXceiver thread name for readBlock and keepalive
> ----------------------------------------------------------------------
>
>                 Key: HDFS-3375
>                 URL: https://issues.apache.org/jira/browse/HDFS-3375
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: data-node
>    Affects Versions: 2.0.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>            Priority: Trivial
>         Attachments: hdfs-3375.txt
>
>
> Currently the datanode thread names include the client for write operations, but not
for read. We should include the client name for read ops. Additionally, in the keepalive phase,
we should include the client name that initiated the previous request as well.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message