hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3282) Expose getFileLength API.
Date Wed, 18 Apr 2012 03:21:15 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3282?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13256166#comment-13256166

Tsz Wo (Nicholas), SZE commented on HDFS-3282:

Uma, good work!  Some comments:
- Let's put HdfsDataInputStream in org.apache.hadoop.hdfs.client.  It is a package for all
the public APIs.
- HdfsDataInputStream.getAllBlocks() should be public.  You also have to change DFSInputStream.getAllBlocks()
to public.
- Move the @SuppressWarnings("deprecation") annotation on DistributedFileSystem to DistributedFileSystem.reportChecksumFailure(..).
 Otherwise, it will suppress all the warnings in DistributedFileSystem.
- Let's replace the javadoc of DFSDataInputStream with "@deprecated use {@link HdfsDataInputStream}
> Expose getFileLength API.
> -------------------------
>                 Key: HDFS-3282
>                 URL: https://issues.apache.org/jira/browse/HDFS-3282
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs client
>    Affects Versions: 3.0.0
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>         Attachments: HDFS-3282.patch
> This JIRA is to expose the getFileLength API through a new public DistributedFileSystemInfo
> I would appreciate if someone suggest good name for this public class.
> Nicholas, did you plan any special design for this public client class?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message