hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uma Maheswara Rao G (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3282) Expose getFileLength API.
Date Wed, 18 Apr 2012 01:21:13 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3282?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13256124#comment-13256124
] 

Uma Maheswara Rao G commented on HDFS-3282:
-------------------------------------------

Thanks a lot for your clarification.
{quote}
Let me clarify it: the return type is HdfsDataInputStream but the return object is still DFSDataInputStream
so that users could cast the stream to DFSDataInputStream as before. We also have to keep
the DFSDataInputStream constructor.
{quote}
Yep, While implementing I got it. Implemented in this way only :-). Otherwise keeping DFSDataInputStream
extends HdfsDataInputStream, almost no use. 

                
> Expose getFileLength API.
> -------------------------
>
>                 Key: HDFS-3282
>                 URL: https://issues.apache.org/jira/browse/HDFS-3282
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs client
>    Affects Versions: 3.0.0
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>
> This JIRA is to expose the getFileLength API through a new public DistributedFileSystemInfo
class.
> I would appreciate if someone suggest good name for this public class.
> Nicholas, did you plan any special design for this public client class?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message