hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3282) Expose getFileLength API.
Date Mon, 16 Apr 2012 19:20:19 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3282?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13254941#comment-13254941
] 

Tsz Wo (Nicholas), SZE commented on HDFS-3282:
----------------------------------------------

Hi Uma,

We could move DFSClient.DFSDataInputStream to a new class, say org.apache.hadoop.hdfs.client.HdfsDataInputStream,
which is a public API.  Then, change the return type of DistributedFileSystem.open(..) to
HdfsDataInputStream.  What do you think?
                
> Expose getFileLength API.
> -------------------------
>
>                 Key: HDFS-3282
>                 URL: https://issues.apache.org/jira/browse/HDFS-3282
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: hdfs client
>    Affects Versions: 3.0.0
>            Reporter: Uma Maheswara Rao G
>            Assignee: Uma Maheswara Rao G
>
> This JIRA is to expose the getFileLength API through a new public DistributedFileSystemInfo
class.
> I would appreciate if someone suggest good name for this public class.
> Nicholas, did you plan any special design for this public client class?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message