hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3131) Improve TestStorageRestore
Date Tue, 27 Mar 2012 14:00:31 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3131?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13239479#comment-13239479
] 

Hudson commented on HDFS-3131:
------------------------------

Integrated in Hadoop-Mapreduce-trunk #1032 (See [https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1032/])
    HDFS-3131. Improve TestStorageRestore. Contributed by Brandon Li. (Revision 1305688)

     Result = SUCCESS
atm : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1305688
Files : 
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
* /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestStorageRestore.java

                
> Improve TestStorageRestore
> --------------------------
>
>                 Key: HDFS-3131
>                 URL: https://issues.apache.org/jira/browse/HDFS-3131
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 0.24.0, 1.1.0
>            Reporter: Tsz Wo (Nicholas), SZE
>            Assignee: Brandon Li
>            Priority: Minor
>              Labels: newbie
>             Fix For: 0.24.0, 1.1.0
>
>         Attachments: HDFS-3131.branch-1.patch, HDFS-3131.patch, HDFS-3131.patch
>
>
> Aaron has the following comments on TestStorageRestore in HDFS-3127.
> # removeStorageAccess, restoreAccess, and numStorageDirs can all be made private
> # numStorageDirs can be made static
> # Rather than do set(Readable/Executable/Writable), use FileUtil.chmod(...).
> # Please put the contents of the test in a try/finally, with the calls to shutdown the
cluster and the 2NN in the finally block.
> # Some lines are over 80 chars.
> # No need for the numDatanodes variable - it's only used in one place.
> # Instead of "xwr" use "rwx", which I think is a more common way of describing permissions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message