hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2904) HA: Client support for getting delegation tokens to an HA cluster
Date Thu, 16 Feb 2012 02:15:05 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2904?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13209073#comment-13209073

Aaron T. Myers commented on HDFS-2904:

The patch looks pretty good to me, Todd. A few small comments:

# Seems like DFSClient#getNNProxy can be made static. Also, please add a method comment for
this method.
# The method comment for HAUtil#CreateFailoverProxy(Configuration, URI, Class) doesn't have
an @param for conf.
# In general I really like proxy creation refactors you did, but does it not seem odd to you
that HAUtil#createProxy might now return a non-HA proxy? Perhaps this method should be moved
to DFSUtil?
# Should HA_DT_SERVICE_PREFIX not be moved to HdfsConstants?
# "HAUtil#cloneDelegationTokenForHAURI" - it's kind of rough that we have two initialisms
run together in this method name. Perhaps s/HA/Logical/ ? Given that the method is in HAUtil,
the context should be clear.
# I don't think there's any need to catch/fail here, can just let the exception be thrown
(in two places):
} catch (IOException e) {
  fail("Could not renew delegation token for user "+longUgi);
# Nit: Please put a blank line after TokenTestAction.
# Nit: All of your doAs blocks could return Void instead of Object.
# Nit: Please put a space after "//" in "//try renew with long name" in two places.
# Nit: Please put a blank line between the methods in ProxyAndInfo.
# Nit: Let's put the "HA case" in HAUtil#createProxy in an "else { }" block for clarity.
# Nit: There's some inconsistency in the patch with regard to indenting 2 spaces or 4 on lines
which go over 80 chars.
> HA: Client support for getting delegation tokens to an HA cluster
> -----------------------------------------------------------------
>                 Key: HDFS-2904
>                 URL: https://issues.apache.org/jira/browse/HDFS-2904
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ha, hdfs client, name-node, security
>    Affects Versions: HA branch (HDFS-1623)
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>            Priority: Critical
>         Attachments: hdfs-2904.txt, hdfs-2904.txt, test-dt.sh
> Currently we have server-side support for delegation tokens in HA, and some tests to
verify it, but the client throws NPEs when trying to fetch a DT. This is because the cluster
doesn't have a single hostname, but instead a logical nameservice name.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message