hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3003) DFSUtil is a better palce for method getHostPortString() than NameNode
Date Thu, 23 Feb 2012 20:26:48 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3003?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13215018#comment-13215018
] 

Aaron T. Myers commented on HDFS-3003:
--------------------------------------

Hey Brandon, I agree that moving the method out of NameNode makes sense. One question - have
you considered perhaps moving it somewhere even *more* generic? Perhaps somewhere in Common?
This functionality doesn't seem DFS-specific to me, either.
                
> DFSUtil is a better palce for method getHostPortString() than NameNode
> ----------------------------------------------------------------------
>
>                 Key: HDFS-3003
>                 URL: https://issues.apache.org/jira/browse/HDFS-3003
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: name-node
>    Affects Versions: 0.24.0
>            Reporter: Brandon Li
>            Assignee: Brandon Li
>            Priority: Trivial
>         Attachments: HDFS-3003.patch
>
>
> The method getHostPortString() is not directly related with NameNode, and it's more of
a utility method.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message