hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sho Shimauchi (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-3014) FSEditLogOp and its subclasses should have toString() method
Date Sun, 26 Feb 2012 02:29:48 GMT

    [ https://issues.apache.org/jira/browse/HDFS-3014?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13216615#comment-13216615

Sho Shimauchi commented on HDFS-3014:

Can you tell me why String.format() is better than StringBuilder in this case?
StringBuilder is better than String.format() in performance I think.
Additionally, StringBuilder is used 456 times in trunk while String.format() is used 242 times.
That mean StringBuilder seems to be more common in code.
I don't think StringBuilder + append() is less readable than String.format(), but if you feel
so, I'll change the format.
> FSEditLogOp and its subclasses should have toString() method
> ------------------------------------------------------------
>                 Key: HDFS-3014
>                 URL: https://issues.apache.org/jira/browse/HDFS-3014
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>    Affects Versions: 0.23.0
>            Reporter: Sho Shimauchi
>            Assignee: Sho Shimauchi
>         Attachments: HDFS-3014.txt
> FSEditLogOp and its subclasses should have toString() method.
> It's helpful for investigating editlog related issues.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message