hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2843) Rename protobuf message StorageInfoProto to NodeInfoProto
Date Fri, 27 Jan 2012 01:06:38 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13194335#comment-13194335

Aaron T. Myers commented on HDFS-2843:

bq. I would argue that the information currently in StorageInfo is not storage specific at

I think I wasn't entirely clear before. I agree that this information usually only needs to
be stored once at the node level. But, it's still information that's specific to "storage"
in the general sense, although it's not specific to a single storage directory. Hence, if
we're going to rename it, I might suggest something like "NodeStorageInfo", which communicates
both that it's at the node level, but only information about storage.

That said, what about during a distributed upgrade process which will change the layoutVersion?
Imagine a scenario where a DN dies during an upgrade while writing the VERSION files to its
various storage directories, and hence only some subset of the directories get the updated
VERSION file. Would we then need to know what layoutVersion is present in each storage directory
separately? I haven't checked on how this case is handled - just thinking out loud.
> Rename protobuf message StorageInfoProto to NodeInfoProto
> ---------------------------------------------------------
>                 Key: HDFS-2843
>                 URL: https://issues.apache.org/jira/browse/HDFS-2843
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-2843.patch
> StorageInfoProto has cTime, layoutVersion, namespaceID and clusterID. This is really
information of a node that is part of the cluster, such as Namenode, Standby/Secondary/Backup/Checkpointer
and datanodes. To reflect this, I want to rename it as NodeInfoProto from StorageInfoProto.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message