hadoop-hdfs-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HDFS-2843) Rename protobuf message StorageInfoProto to NodeInfoProto
Date Thu, 26 Jan 2012 23:45:41 GMT

    [ https://issues.apache.org/jira/browse/HDFS-2843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13194285#comment-13194285

Suresh Srinivas commented on HDFS-2843:

I would argue that the information currently in StorageInfo is not storage specific at all.
Current information in StorageInfo is : namespaceID, layoutVersion, cTime and clusterID. All
these are node level information and are common for all the storages, that a node manages.

If you look at the proposal from 2832, and treat say a datanode as collection of storages,
all the above information is needed only once at the datanode level and not per storage level.
> Rename protobuf message StorageInfoProto to NodeInfoProto
> ---------------------------------------------------------
>                 Key: HDFS-2843
>                 URL: https://issues.apache.org/jira/browse/HDFS-2843
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: data-node, name-node
>            Reporter: Suresh Srinivas
>            Assignee: Suresh Srinivas
>         Attachments: HDFS-2843.patch
> StorageInfoProto has cTime, layoutVersion, namespaceID and clusterID. This is really
information of a node that is part of the cluster, such as Namenode, Standby/Secondary/Backup/Checkpointer
and datanodes. To reflect this, I want to rename it as NodeInfoProto from StorageInfoProto.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message